Server Issues Jan 25th 23

Classic British Flight Sim forum.
Support for Maltby/Piper FS models & other Classic British freeware.

Moderators: Guru's, The Ministry

User avatar
TSR2
The Ministry
Posts: 15593
Joined: 17 Jun 2004, 14:32
Location: North Tyneside, UK
Contact:

Server Issues Jan 25th 23

Post by TSR2 »

Hi all, Some issues with the webserver. The forum seems fine, but the home page and other associated pages are coming up with a 500 error. It might take me a day or two to resolve. Sorry for the inconvenience :cpu:
Ben.:tunes:

ImageImageImage

Filonian
Red Arrows
Red Arrows
Posts: 6383
Joined: 27 Nov 2005, 08:08
Location: Gristhorpe, UK

Re: Server Issues Jan 25th 23

Post by Filonian »

No problem Ben. Just grateful for all you do. I'm sure you will sort it. :thumbsup:

Graham
Image
The early bird gets the worm, but the second mouse gets the cheese.

User avatar
TSR2
The Ministry
Posts: 15593
Joined: 17 Jun 2004, 14:32
Location: North Tyneside, UK
Contact:

Re: Server Issues Jan 25th 23

Post by TSR2 »

Sorry lads, I haven't been well for a few days so only getting a chance to look properly now. The website uses a file type called PHP which is very common on the internet. It seems that some sort of recent update has meant that PHP files in the root of the website cannot be processed by the part of the system that interprets PHP files. This is why the forum is working, but the main site (which is in the root of the file structure) doesn't.

I'll chip away at this tonight, but it means moving the home page files from the root, to a sub folder... which in itself is easy enough, but I will need to update the code in these files and as it was something DM did years ago, it might take me a while to try and figure it out. :cpu:
Ben.:tunes:

ImageImageImage

User avatar
TSR2
The Ministry
Posts: 15593
Joined: 17 Jun 2004, 14:32
Location: North Tyneside, UK
Contact:

Re: Server Issues Jan 25th 23

Post by TSR2 »

Back again.. well the forum is anyway. the server has been completely rebuilt from scratch and still the php files on the homepage won't load, yet the form which is also php works fine.

I've also tried putting a generic php file in on the homepage and that strangely also works, so it looks like there is something in the code in our website pages that is no longer supported.

To keep things ticking over I've brought the forum back up so that we can at least have a chat. :cpu:
Ben.:tunes:

ImageImageImage

User avatar
DaveG
The Gurus
Posts: 7663
Joined: 23 Jun 2004, 18:05
Location: in a deep, dark hole somewhere.
Contact:

Re: Server Issues Jan 25th 23

Post by DaveG »

Roger that Ben. :thumbsup: Thanks for all the hard work. :cheers:
Dave G.

adysmith
VC10
VC10
Posts: 563
Joined: 12 Jun 2013, 11:43
Location: EGNH

Re: Server Issues Jan 25th 23

Post by adysmith »

I had been worrying what had gone wrong, keep up the good work, we all appreciate it.
ImageImage
Image
Old pilots never die, they just run out of runway.

User avatar
TSR2
The Ministry
Posts: 15593
Joined: 17 Jun 2004, 14:32
Location: North Tyneside, UK
Contact:

Re: Server Issues Jan 25th 23

Post by TSR2 »

I realised thanks to Kevin actually that a lot of people may have bookmarked the CBFS_HOME.php page. Up until last night anyone going directly there would still have got the error, but I stripped the code from that page and put a redirect directly to the forum, so now at least everyone should be able to get here.
Ben.:tunes:

ImageImageImage

User avatar
Tomliner
Battle of Britain
Battle of Britain
Posts: 4945
Joined: 02 Apr 2006, 12:00
Location: Edinburgh UK

Re: Server Issues Jan 25th 23

Post by Tomliner »

Thanks again for what you do Ben. I suspect some of us were getting withdrawal symptoms! :agree: EricT
Now at the age where I know I like girls but can't remember why!

User avatar
AllanL
Concorde
Concorde
Posts: 813
Joined: 06 Sep 2005, 21:01
Location: Scotland

Re: Server Issues Jan 25th 23

Post by AllanL »

Well done Ben. It all started going downhill when we stopped getting lasses to punch code into tape. :guinn:

User avatar
TSR2
The Ministry
Posts: 15593
Joined: 17 Jun 2004, 14:32
Location: North Tyneside, UK
Contact:

Re: Server Issues Jan 25th 23

Post by TSR2 »

:lol:
The problem is we no longer have someone with DM’s website coding skills, so when something is depricated I’ve no idea how to fix it.

It turns out the code the was used to cycle through the images on the homepage is no longer supported. I’m not entirely sure why, or how to fix it, so I’ve commented it out for now. :cpu:
Ben.:tunes:

ImageImageImage

Post Reply